PHP is amongst the most widely used open-source scripting languages. It is highly popular as it is free software, which can be used to build responsive sites like community websites, web shops or e-teaching sites rather than static HTML websites. A PHP module should be activated on the web server where a PHP-powered website is hosted so that its source code can be ‘deciphered’. Since there are no license fees for this kind of module and the language provides incalculable possibilities for the apps that you build, there’re 100s of millions of PHP-powered websites. Furthermore, there are a large number of PHP scripts, which you can use for your sites without the need to possess any programming knowledge. Considering the fact that there’re a handful of versions of PHP, you should check whether the very same version that you used whilst creating your website is available on the server as well.
PHP 4, PHP 5 and PHP 7 Support in Website Hosting
We have reached a decision not to prevent our present and future customers from picking the PHP version that will be used by their websites, which suggests that in case you order a website hosting package from us, you’ll be able to pick between versions 4, 5 and 7, not only for the web hosting account itself, but also for each domain that you host. This can be done with just one single mouse click from our custom-created Hepsia Control Panel via which all shared web hosting accounts are administered, so you won’t need to have any technical or coding skills. You’ll be able to manage sites built with both new and old PHP scripts without having to cope with any complications, so if you would like to drop your present provider and move over to us, you can be sure that all the sites that you’ve created through the years will continue to work properly.
PHP 4, PHP 5 and PHP 7 Support in Semi-dedicated Hosting
If you’ve got a website based on an earlier PHP version and you have contributed time and energy to developing it, plugging safety breaches and appending content, you will need to find a hosting service that can support it, as most hosting providers nowadays offer support only for the most recently released version of PHP and give up the earlier versions. We, on the other hand, have decided to permit you to choose the version that your own websites need. Our Linux semi-dedicated services support PHP 4, PHP 5 and PHP 7, which implies that you’ll be able to run both newer and older scripts without losing any custom tweaks or misspending time and energy attempting to make your websites compatible with the hosting environment. You can change the current version via the Hepsia hosting Control Panel and such a change will apply to the whole semi-dedicated account, but you’ll also have the ability to choose a different version of PHP for each single website that you host in your account by means of an .htaccess config file.